[リストへ戻る]
一括表示

タイトル
記事No
投稿日
投稿者
参照先
Re: ジャケット表示について
291
: 2014/01/23(Thu) 17:46:27
K-N

> はじめまして。こちらのHPを参考にさせていただき、PCにて快適に音楽を楽しめるようになりました。
>
> 初歩的な質問で恐縮です。
> HPに記載されている方法でCDをリッピングし保存しておりますが、取り込む際、EAC上ではジャケット写真が表示されていてもfoobar2000上では表示されないことが極まれにおこってしまいます。>
> フォルダを見てみますと、元のデータがJPEGであっても、ファイルの種類が「ファイル」としか表記されておりませんでした。
> (通常であれば「JPEGファイル」と表記されると思います)。
>
> なお、データを削除した上で再度CDのリッピングを試みてみたのですが、同様に結果となります。
>
> 設定や操作はHP上の方法にて行っていると思いますが、考えられる不備などはありますでしょうか。

タイトル
記事No
投稿日
投稿者
参照先
Re^2: ジャケット表示について
292
: 2014/01/24(Fri) 23:46:40
kazutomo

書き込みありがとうございます。

HPに記載されている方法と言うのはEACとEasyWavPackを
使った方法でしょうか?

特に画像を埋め込む前に画像の整合性のようなものは
確認しておらず、拡張子が.jpg .png .bmpの3種類
であればそのまま埋め込むプログラムになっています。

考えられることとしては・・・
・画像ファイルが破損している
・拡張子が.jpg .png .bmp以外でwavpackに埋め込みされていない
・表示できる画像ファイル規格から外れている

が思いつきます。ちゃんと埋め込まれたかどうかは
変換後、EasyWavPackのフォルダのeasywavpack.log
で確認できると思います。
画像ファイル :******.jpg
という行が入っていれば一応は埋め込まれていると思います。
なければ画像ファイルが認識できないということになります。

他の画像でやっても駄目なんでしょうか?

タイトル
記事No
投稿日
投稿者
参照先
Re^3: ジャケット表示について
293
: 2014/01/25(Sat) 08:25:11
K-N

kazutomoさま


ご返答ありがとうございます。

拡張子の破損等は見受けられなかったため、こちらの設定や方法のミスがあったかと思い、書き込みをさせていただきました。

他の画像を用いるときちんと保存できました。

今後も、EasyWavPackを利用させていただきます。

タイトル
記事No
投稿日
投稿者
参照先
Re^4: ジャケット表示について
304
: 2014/05/13(Tue) 07:46:03
KohFlag
http://sonicdisorder.net/cgi/wforum/wforummp.cgi?mode=relate&no=38&page=40
kazutomoさま
K-Nさま

突然申し訳ございません。
KohFlagと申します。
初めて書き込みいたします。

最近、EACやEasyWavPackを使い始めました。

EACのバージョンは、1.0beta3
EasyWavPackのバージョンは、easywavpack26

です。

こちらのHPは大変助かっております。
ありがとうございます。

本タイトルの件につきまして、私自身もK-Nさま
と同様の現象が発生しており、その現象に対して行った
対策も含めてご報告したく思います。
今回の現象については、対策を行った結果、

EACの「エンコードオプション」ー「ID3タブ」の「取り込み先フォルダにジャケット画像を保存する」の
ファイル名の書式を

%albumartist% - %albumtitle%.jpg

という様に、
デフォルトの文字列の末尾にJPEGファイルの拡張子(.jpg)を追加して指定するのが有効と考えています。

それでは、ご報告いたします。

(現象)

1. こちらのHPの記載内容に沿って、音楽CDからWavPack(.wvファイル)を作成(1度目)。
ジャケット画像の元データはJPEGデータです。
プレビューが普通にできる(表示も普通です)ので、破損はしていないと思います。

WavPackを作成したフォルダを確認してみると、次の様なファイルができていました。

・保存されたファイル名.wv
・保存されたファイル名.wav
・保存されたファイル名.cue
・保存されたファイル名.log ←eacオプションのツールタブでlogファイルを保存する設定にしています。
・保存されたファイル名 ←拡張子の無いファイル。ファイルの種類はファイル。※K-Nさまと同様の現象。

この時点で、画像(.jpg)ファイルがないのですが、とりあえずfoobar2000上で確認する事にしました。

2. foobar2000上で、作成したWavPackを再生。
再生は特に問題無くできたのですが、ジャケット画像が表示されていませんでした。
原因はなんだろう・・・と、こちらのHPやその他のWeb上の記載を見たりしながら考えました。
その結果、やはり、WavPackのあるフォルダ内の拡張子の無いファイルが怪しい・・・と考え至りました。


(対策)
1. WavPackのあるフォルダ内の拡張子の無いファイルの名前を変更。

拡張子が無いファイルでしたので、試しに.jpgを付けてみようと考え、

保存されたファイル名 → 保存されたファイル名.jpg

にファイル名を変更してみました。
すると、ファイルの種類がJPEGイメージに変化し、プレビューしてみると、
ジャケット画像の元データと同じ画像が表示されました。

2. 現象発生時のフォルダ構成を保ったまま、1度目と同じ条件で、同じフォルダにWavPackを再度作成(2度目)。

WavPackを作成したフォルダを確認してみると、今度は次の様なファイルができていました。

・保存されたファイル名.wv
・保存されたファイル名.wav
・保存されたファイル名.cue
・保存されたファイル名.log
・保存されたファイル名.jpg ←対策1で名前変更したファイル。
・保存されたファイル名 ←拡張子の無いファイル。ファイルの種類はファイル。今回の再度の作成でできたと考えます。

この時点で、また拡張子の無いファイルができているのですが、とりあえずfoobar2000上で確認する事にしました。

3. foobar2000上で、作成したWavPackを再生。
再生は特に問題無くでき、ジャケット画像も表示される様になりました。
これで、1度目のWavPack作成では埋め込み用のJPEGファイルが作成できず、拡張子の無いファイルになってしまった為、
WavPackに埋め込みできず、foobar2000上でも表示できなかったと判断しました。

4. 拡張子の無いファイルが作成される原因の特定
1度目のWavPack作成において、私はこちらのHPの記載内容に沿いました。
その結果、JPEGファイルが作成できず、拡張子の無いファイルができてしまったという事は、
埋め込み用のJPEGファイル作成の為に、EACやEasyWebPackの設定で必要な事がまだあるのではと考えました。
ちなみに、ジャケット画像の元データを別の画像に変更した上でWavPackの作成を実行しても、拡張子の無いファイルが作成される現象は変わらず発生し、
画像埋め込みは行われませんでした。
この事から、WavPack作成時の処理に何かある・・・と考えが進みました。

その後、原因の特定と改善の為、こちらのHPやその他のWeb上の記載を見たりしながら考えました。
その結果、掲示板内の

folder.jpgが出力されない

の記事にて、kazutomoさまが書かれていた、画像保存の設定の部分に改善の余地ありかも!?と考え至りました。

5. EACの「エンコードオプション」ー「ID3タブ」の「取り込み先フォルダにジャケット画像を保存する」の部分を見直し
こちらの設定は、「取り込み先フォルダにジャケット画像を保存する」にチェックを入れ、ファイル名の書式は
デフォルトのままの、

%albumartist% - %albumtitle%

にしておりました(上記の1度目と2度目のWavPack作成時において)。

ここのファイル名の書式をしばらく眺めていて、拡張子の指定が無い事に気付きました。
それで、ファイル名の書式・・・ということであれば、ファイル名の他に拡張子も含めて指定すべきではないか?と考え至りました。
そこで、ファイル名の書式の設定を次のように書き換えました。

%albumartist% - %albumtitle%.jpg

デフォルトの設定の文字列の末尾に .jpgとJPEGファイルの拡張子を追加しました。

6. WebPackを新規作成。
1度目および2度目と同じ音楽CD、ジャケット画像の元データ(JPEGファイル)を使いました。
WebPackの保存先は、1度目および2度目とは別の場所に指定しました。
また、EACやWebPackの設定は、画像保存のファイル名の書式のみ、5.の通り変更している以外は、こちらのHPの内容に沿いました。

WavPackを作成したフォルダを確認してみると、今度は次の様なファイルができていました。

・保存されたファイル名.wv
・保存されたファイル名.wav
・保存されたファイル名.cue
・保存されたファイル名.log
・保存されたファイル名.jpg

拡張子の無いファイルは存在せず、JPEGファイルが作成されていました。
この状態ならジャケット画像の埋め込みはできているかも!?と判断しました。

7. foobar2000上で、作成したWavPackを再生。
再生は特に問題無くでき、ジャケット画像も表示される様になりました。

(考察)
以上の結果から、 埋め込み用のJPEGファイルを正常に作成する為には、
EACの「エンコードオプション」ー「ID3タブ」の「取り込み先フォルダにジャケット画像を保存する」の所のファイル名の書式を、

%albumartist% - %albumtitle%.jpg

という様に、
デフォルトの文字列の末尾にJPEGファイルの拡張子(.jpg)を追加して指定するのが有効と判断しました。
これにより、WavPack作成時に埋め込み用のJPEGファイルが作成でき、画像埋め込みも成功すると考えます。

ご報告は以上になります。
こちらの掲示板を見ていて、私自身も同様の現象に悩まされ、試した事があった為、ご報告も兼ねて書き込んでみたくなりました。

長文、乱文、申し訳ございませんでした。

EAC、EasyWebPack、LAMEなどのツールは、今後もPCや携帯プレーヤーで音楽を楽しむにあたり、有用と考えております。
今後も使わせて頂きます。

こちらのHPも今後も参考にさせて貰えればと思います。

今後もお世話になります。

タイトル
記事No
投稿日
投稿者
参照先
Re^5: ジャケット表示について
305
: 2014/05/13(Tue) 22:29:30
kazutomo

書き込みありがとうございます。

また、詳細な実験、レポートしていただきありがとうございます。
もしかしたらこの方法でうまく作れる方も出てくるのでは
ないかと思います。

私の環境 Windows 7で設定を確認してみたところ
「%albumartist% - %albumtitle%」
でした。触った記憶はないのでデフォルト設定だと思います。
これで画像入りWavpackを作れています。

EACがどのような処理をしているのかわかりませんが、
拡張子をつける場合とつけない場合の条件があるようですね。
(まさか、ファイルの拡張子表示をしているかしていないか
 とかではないと思いますが・・・あとOSがWindows8とか)

EasyWavPackは拡張子でしか判断していないので
画像ファイルの拡張子がついていないと画像として認識しません。
ヘッダとか解析したら拡張子使わなくてもよさそうですが・・・
そこまで画像添付するのに判定処理を入れるかどうかですね。
(バージョンアップ予定はないですが・・・)

とりあえず解決方法があったようなのでよかったです。
ありがとうございました。


タイトル
記事No
投稿日
投稿者
参照先
Re^6: ジャケット表示について
306
: 2014/05/14(Wed) 03:33:09
KohFlag
http://sonicdisorder.net/cgi/wforum/wforummp.cgi?mode=relate&no=38&page=40
kazutomoさま

お返事ありがとうございます。

先のご報告時に、PC環境を書き忘れていました。
申し訳ございません。

私のPC環境は、OSがWindows 7 Ultimate SP1 64bitになります。

kazutomoさまと同じWindows 7なのですが、EACの画像保存設定が

「%albumartist% - %albumtitle%」

のままだと、何度WavPackの作成を実行しても、
拡張子の無いファイル(JPEGなど画像ファイルになる筈のファイル)
が作成され、画像の埋め込みは行われませんでした。

また、頂いたお返事を読んだ後で、Windowsのフォルダオプションで、

登録されている拡張子は表示しない

のチェックのON/OFFをやってみたりもしましたが、いずれも画像保存設定が上記のままだと画像埋め込みは行われませんでした。

何故私のPCはできないのか・・・気になるところです。
ただ、私のPC環境の場合、EACの画像保存設定を

「%albumartist% - %albumtitle%.jpg」

の様に拡張子を付ければ、WavPack作成時に画像埋め込みが行われる様になります。
とりあえず、私はこれで運用していこうと思います。

今回はありがとうございました。

タイトル
記事No
投稿日
投稿者
参照先
Re^7: ジャケット表示について
393
: 2014/11/30(Sun) 20:23:04
Mikio

今更ながらクリティカルな内容でしたので横槍を...

当方の環境は
Windows7Pro SP1(64bit)
EAC Ver 1.0beta3
EasyWavPack 2.6
と言う環境です。

現状私の場合物によって発生したり/しなかったり(発生する物は100%発生し、発生しない物は100%発生しない)となっています。
原因としてはおそらく画像ファイルその物に何か原因がある様に思います。

私が確認した限りでは問題の発生した画像ファイル(JPEG形式)をフォトレタッチソフト(GIMP2)にてイメージを新規画像にコピーし、別ファイルとしてエクスポートしたファイル(JPEG形式)ではファイル名の拡張子は正しくコピーされる様でした。

とりあえず1アルバムでの検証のみですので、実際にはもっと多くのサンプルが必要となってしまうでしょうけれど、一応参考までに。


で、実際私としては、楽曲の取り込みが始まった時点で画像ファイルの複写は済んでいる様ですので、そのファイルにファイル名変更にて直接拡張子を追加しています。

- WebForum -